Generic host process for win32
Bonjour,
j'ai un parc d'ordinateurs connectés en WIFI a internet via un router WIFI. meme configuration sur les machines de mon reseau et meme installation :
-Windows XP Service Pack 3
-Ms office
-Firefox mozilla 3
-Aucune protection antivirus ni par-feur (suite a l'utilisation de deep freez version administrable)
-Utilitaires pour utilisation normale d'internet (MSN / Realplayer / PDVD/etc...)
-Adoble flash player a jour (version 10...)
-Java (update 11)
Mon souçi c'est avec le message d'erreur (Generic host process for windows 32 rencontré un problem et doit se fermer) et directement aprés le message, le theme windows qui se perturbe (perte des couleurs) et le systeme qui se plante pour quelques instants. aussi le service (Audio windows ) qui s'arret directement aprés le message d'erreur !!!
J'ai essaye le formattage et la remise a jour de toutes mes applications et utilisant multiples anvirivurs pour voir si ya un virus caché quelquepart, rien trouvé !!!
En surveillant les processus actifs (rien constaté d'anormal du coté processus et consommation de la RAM, meme au moment du message d'erreur) .
NB : le message se genére meme en mode sans echec !!! et meme sans connexion active au réseau local ni a internet !!!!
Désormais, mes ordinateurs démarrent en une minute ce qui est pas normal par rapport a l'avant et les commandes se bloquent (souris / copie et coller / gestionnaire des taches ) et je repéte que toutes les machines sont equipés de deep freez et meme ce dernier a eté reinstallé aprés les tests sur chaqu'une des machines !!
J'ai parcouru les forums franco et anglo et j'ai vu que c'est un ancien problem qui remonte encore, je demande au gens ayant de l'expérience avec ça de bien vouloir nous expliquer est ce qu'il s'agit d'un virus ou juste un bug windows a corrigé !!! et c'est pour le bien de nous tous. merci et desolé pour le long poste.

j'ai essayé tout cequi est possible et seule l'installation de zonealarm a annulé le probléme du message et plantage !!

zonealarm m'indique de temps en temps qu'il a bloquer une menace vers svchost.exe venant d'une adresse privé de type 192.XXXXXXX sur un protocole netBios !!

Voir capture d'ecran : [img513.imageshack.us]

quelqu'un peut nous expliquer !!

merci
Bonjour,

Tu dois supprimer une clé dans le registre..

Mais vu que tu te connais en informatique,tu dois pouvoir régler ton problème tout seul...

Bonne chance!
Rebonjour,
je comprend pas l'utilité de poster un message si c'est pour dir n'importe quoi !!
j'ai posté ce problem sur plus que 20 forums en anglais et arabe et français juste prck j'ai essayé toutes les manipulations possibles (manip trouvées sur d'autres forums) et la seule manip qu'a bloquer le souçi c'est zonealarm mais qd meme je cherche l'explication des menaces bloquées sur svchost !!
NB : c'est pas forçément que je suis le seul beneficiare des réponses. j'ai posté le problem d'une façon a permettre au milliers personnes yant le meme souçi d'avoir une meilleure idée.
Si vous permettez de me montrer la clé a supprimer je vous seré reconnaissant !!
Merci
Procède comme suit:

clic sur "Démarrer" puis sur "Exécuter" et tape regedit

clic ensuite sur:

HKEY_LOCAL_MACHINE
SOFTWARE
Microsoft
Windows
CurrentVersion

Double-clic sur "Run"

Dans le volet de droite, clic droit sur la clé WinprocAudit puis supprime-la

Tiens-nous au courant.
aucune clé avec ce nom et pourtant, cet volet est vide (aucune application ne se lance au demarrage)

merci
Interessant!

Pas de clé..et vu que svchost est un ccomposant logiciel du sysyème Windows,chargé d'activer les

différents services liés à Windows ou à Internet,et que dans le passé,des virus étaient capables

d'infecter ce programme,et que la faille a été depuis longtemps colmatée par Microsoft,il reste à

exploiter d'autres hypothèses. Je te propose de faire ceci:



clic sur "démarrer","panneau de configuration",clic sur "Services"

Dans la fenêtre qui apparait,double-clic sur la ligne "Affichage des messages"

Dans la fenêtre qui suit,clic sur "Type de démarrage",sélectionne "Désactivé",puis clic sur "Ok"


Si le problème persiste,cela veut dire que le service DNS a un conflit avec le pare-feu..fais alors ceci:


clic sur "démarrer","panneau de configuration", "clic sur "Pare-feu de Windows" et mets le "Activé"

désinstalle ZoneAlarme,puis réinstalle la dernière version.

Tiens-nous au courant.


ps: ne t'enflamme pas pour si peu,je n'ai rien voulu suggerer,je sais que tu as soulevé ce problème dans différents forums..Aussi,je voulais simplement que tu trouves la solution de ton propre chef.
Merci chéf,
les manipulations que vous proposez sont déja executées et juste pour la certitude, j'ai refait selon l'ordre que vous avez mis et ça change rien . l'utilisation de zonealarm résout le souçi du message d'erreur et annule tt les plantages et symptoms apparants mais y'a tjrs les menaces bloqués sur svchost (selon zonealarm) avec une seuile d'une menace par 5 minutes

a vous et merci
Salam,

Doublement intéressant...

1. la clé "Run" est vide
2. Le service des message est désactivé...

Reste le virus Blaster.

Je te préconise de faire ceci dans l'ordre:

1. Ferme le processus "MsBlast.exe"

2.Installe le correctif de Microsoft ( fichier KB823980-x86FR.exe )

3.Désinfecte ton micro en téléchargeant le fichier FixBlast.exe

Tiens-nous au courant.
bonjour.
ce n'est pas le virus blaster vue l'absence des symptomes et processus relativs.
j'ai tjrs les menaces bloqués chaque 4 ou 5 minutes sur svchost provenant de l'adresse meme de mon ordinateur en reseau local !!!!!!!!
ça commence vraiment a me donner l'envie de detester l'informatique !!
merci pour votre aimabilité ttefois smiling smiley
Salam,

Moi,je suis assuré qu'il s'agit bien du virus Blaster( une variante).

car le message "Generic Host Process for Win32 Services a rencontré un problème et doit fermer" (C'est

bien çà le message?) est lié à la présence du virus Blaster ou une variante dans ton PC..Peut-être un

résidu.

Maintenant si ton pare-feu te signale qu'un programme tente de se connecter à Internet depuis ton micro

et veut envoyer des données vers l'extérieur,rassure-toi ,ce n'est pas un virus. Car,comme je l'ai dis,

svchost (service host) est un composant logiciel du système Windows.

Désactive la restauration du sysyème et fais une analyse en mode sans échec pour voir..

Tiens-nous au courant.
Citation
maroctech a écrit:
bonjour.
ce n'est pas le virus blaster vue l'absence des symptomes et processus relativs.
j'ai tjrs les menaces bloqués chaque 4 ou 5 minutes sur svchost provenant de l'adresse meme de mon ordinateur en reseau local !!!!!!!!
ça commence vraiment a me donner l'envie de detester l'informatique !!
merci pour votre aimabilité ttefois smiling smiley

salam

a ce point la?smiling smiley
Je pense que Je t'ai déjà répondu sur un autre forum
Mais Je ne savais pas qu'il y avait autant d'anomaliesevil
Alors pour éviter de faire une déprime avec ces machines, voici quelques propositions
d’abord pour ton réseau local
si tu as plus de 5 machines, je te conseil de faire un réseau avec câbles( sans routeur)
en utilisant un pc comme (serveur) les autres seront (clients)
avec Windows xp pro, tu peux installer plus de 200 clients sans problème
pour la version familiale 9 maxi.

Mais avant de commencer ,
Etape 1
Je te conseil vivement d’acheter un cd Windows XP pro Service Pack 2. tu peux ensuite faire
La mise a jour vers pack 3 mais le plus tard possible.

Etape 2

Identifier puis copier tous les drivers sur un cd ou dvd + un antivirus.

Etape 3

Formater tous les pc, si possible avec 3 ou 4 partitions,
une pour le fichier d’échange ( mémoire virtuelle)
une pour la récupération system en cas de souci.
Une pour le system
Puis une dernière pour monsieur t le monde.

Etape 4

Réinstaller xp ainsi que tes programmes etc.
Sans oublier l’antivirus sur chaque machine
Tu peux utiliser le pare-feu Windows, pas besoin d’ajouter d’autre
Je l’utilise sur 120 machines, Jamais eu de problème.


Etape 5
Aie !
C’est la plus compliquéangry smiley
Windows XP tt comme -Ms office, doivent être activés
Si non (svchost) risque de réapparaître de nouveau.
Voilà mon cher
Un dernier conseil
Faut pas hésiter de lancer le journal d’événements pour identifier les coupables.
Citation
Le locataire a écrit:
Salam,

Moi,je suis assuré qu'il s'agit bien du virus Blaster( une variante).

car le message "Generic Host Process for Win32 Services a rencontré un problème et doit fermer" (C'est

bien çà le message?) est lié à la présence du virus Blaster ou une variante dans ton PC..Peut-être un

résidu.

Maintenant si ton pare-feu te signale qu'un programme tente de se connecter à Internet depuis ton micro

et veut envoyer des données vers l'extérieur,rassure-toi ,ce n'est pas un virus. Car,comme je l'ai dis,

svchost (service host) est un composant logiciel du système Windows.

Désactive la restauration du sysyème et fais une analyse en mode sans échec pour voir..

Tiens-nous au courant.

Salam,
merci pour l'effort que vous faites en m'indiquant les manip possibles, les intrustions sont en provenance et pas a destination , Svchost reçoit des requetes depuis l'adresse ip de mon ordinateur meme sauf que chaque requete vient avec un port différent. donc c'est sure que c (kelk chose) qui envoie un truc depuis mon poste vers mr le svchost de mon poste !!! mais quel chose ???
une nouveauté pour aujourd'hui !! j'ai formatté 2 ordnateurs en meme temps
les 2 en Cable ethernet avec un simple router vers le net , crack genuine ok ==> activation des maj OK ==> installation des maj jusk'au le sp 3 que j'ai annulé sur une machine mais pas sur l'autre.
j'ai bien verifié les maj pour les applications (office / flash player / java / ie7). la nouvelle c'est que maintenant mr le csrss.exe joue sur mon processeur !!! il saute en permanence de 40% a 100% d'usage CPU ??? [ sur la machine avec SP3], sur l'autre avec seulement le SP2 le message d'erreur de generic host process est reaparu et cette fois meme en utilisant zoneelerm et kaspersky et adware-pro !!!
N ; j'ai formaté l'ensemble de mes machines et a chaque fois quand je réalise mes tests sur une machine . je la connecte directement au router et j'isole les autres.
====

en ce qui concerne la proposition d'utiliser un domain avec un truc du genre client/serveur, je pense pas que c'est convenable vue que c'est juste un cyber !!!!

===

ça commence a devenir bizarros n'est ce pas ? je vous remercie les gars pour vos suggestions je suis dans l'attente de vos contributions afin d'aboutir a une solution
Salam,

C'est plus clair maintenant...et je pense que le problème est cerné maintenant.

Récapitulons:

1. le message d'erreur est lié au virus Blaster mais tu n'as pas trouvé de traces.
2. Zone alarme te signale que le programme svchost.exe ( le sevice Host ) tente de se connecter..

conclusion: les 2 sont liés.

Tu as formaté l'ensemble des machines et le problème subsiste...

MAIS,tu m'apprends que tu utilises aussi le SP2. Peux-tu me confirmer que le message " Généric Host

Process for Win32 services a rencontré un problème et doit fermer" provient d'une machine sous XP SP2 ?


Tiens-nous au courant.
Salam
Oui c’est plus que clair
a présent je sais pourquoi notre ami déteste l’informatique smiling smiley

J’ai teste le tuc par curiosité sur un seul pc avec sp2
Pourquoi ?
C’est parce que j’ai lu quelque part :

La prochaine mise à jour majeure de Windows le Service Pack 2, va désactiver les deux principales méthodes utilisées pour …. système d'exploitation.

Je peux vous dire que j’ai bien réussi, fier de moi mais pas pour longtemps
Car le jour même mr. svchost me demande de régler l’heure et la date puis quelques jours plus
Un autre message puis un autre ainsi de suite..)

Donc en ce qui me concerne, j’ai pas de solution fiable a 100 pour cent
Mais bonne courage.
Salam,

Amesamir,

Tu y es presque...mais réfléchis encore. Notre ami n'avait pas parlé du XP SP2 jusqu'à son dernier message...J'attends une confirmation de sa part.

Zone alarme s'affole et svchost.exe est un programme lié aux services..Ce n'est pas un virus.

Blaster n'est pas présent pourtant le message d'erreur en fait référence.

Si le message vient d'une machine sous XPSP2...la solution est tout près.
Salam locataire
J'ai bien refléchi

Auteur: maroctech [MP]
Date: le 06 janvier 2009 à 13h17

Bonjour,
j'ai un parc d'ordinateurs connectés en WIFI a internet via un router WIFI. meme configuration sur les machines de mon reseau et meme installation :
-Windows XP Service Pack 3

Mais le problème le plus compliqué :

crack genuine ok
tu vois ce que je veux dire ?


svchost.exe je sais ce que c’est
exemple:[zepload.com]
Resalam,

oui,je sais ce que cela veut dire...

Je cite notre ami plus haut: "sur l'autre avec seulement le SP2 le message d'erreur......"

bon,on attend ou plutôt on attendra pour demain inchallah. Bonne nuit!
Bonsoir les amis,
desolé pour le retard . ces derniers jrs je dor plus en essayant de trouver une solution a ce probleme .
le probléme est apparu en meme temps sur 9 machines (WIFI) avec le SP3 et les ajours !! et aussi sur une machine SP3 cablée et un laptop (WIFI) avec le SP2 !!!
le crack gennuine n'est présent que depuis que j'ai commencé les tests donc il fé pas partie des raisons mais pluto de mes tentatives (je pensé que peu etre Mme microsoft a envoyé un mouchard qui attack les non genuine) w lghaleb lah içi au maroc rak t3ref on a pas lkher9a pour acheter une license ni pour un pc ni collective !!
a vous et desolé pour le retard .
Citation
Le locataire a écrit:
Resalam,

oui,je sais ce que cela veut dire...

Je cite notre ami plus haut: "sur l'autre avec seulement le SP2 le message d'erreur......"

bon,on attend ou plutôt on attendra pour demain inchallah. Bonne nuit!

Une autre fois, inchallah, je suis absent
Bonne nuit!
resalam.
je viens encore de faire ce qui suit :

isoler un ordi carrément du reseau et du NET
formater doucement (eviter les virus MBR)
installer win XP Pro edition (SP2)
installer openOffice
installer IE7
Installation de securité (Avira + ZoneAlarm free + Spyware doctor)
connexion directe a internet via liaison Ethernet (les autres ordi sont eteints et tous isolés)
activer windows genuine (avec une license valide et légale de chez un ami)
installer le SP3 correctly
installation des MAJ pour IE7 et le SP3 jusqu'au bout (depuis le windows update center)
début des tests ... pendant 2 premieres heures de travail normal sur le net ya eu 390 tentatives d'accés a svchost (voir image : [img370.imageshack.us] )
j'immagine que si y'avé pas zonealarm qui bloque , j'auré reçu 309 messages d'erreur du generic host process et les symptoms qui suivent son apparition !!!
Réponse a la question : aprés ces manips, je dit que le probléme je lé sur les machines equipées du SP2 et le SP3
a vous !! et mille merci
Facebook